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Honeywell Materials License Agreement

The documents and information contained herein ("the Materials") are the proprietary data of 
Honeywell International Inc. and Honeywell Intellectual Properties Inc (collectively "Honeywell").  
These Materials are provided for the exclusive use of Honeywell Service Centers; 
Honeywell-authorized repair facilities; operators of Honeywell aerospace products subject to an 
applicable product support agreement, their wholly owned-subsidiaries or a formally designated 
third party service provider; and direct recipients of Materials from Honeywell's Aerospace 
Technical Publication Distribution.  The terms and conditions of this License Agreement govern 
your use of these Materials, except to the extent that any terms and conditions of another 
applicable agreement with Honeywell regarding the operation, maintenance, or repair of Honeywell 
aerospace products conflict with the terms and conditions of this License Agreement, in which 
case the terms and conditions of the other agreement will govern.  However, this License 
Agreement will govern in the event of a conflict between its terms and conditions and those of a 
purchase order or acknowledgement.

1.  License Grant – If you are a party to an applicable product support agreement, a Honeywell Service Center 
agreement, or an authorized repair facility agreement, Honeywell hereby grants you a limited, non-exclusive license to 
use these Materials to operate, maintain, or repair Honeywell aerospace products only in accordance with that 
agreement.

If you are a direct recipient of these Materials from Honeywell's Aerospace Technical Publication Distribution and are 
not a party to an agreement related to the operation, maintenance or repair of Honeywell aerospace products, 
Honeywell hereby grants you a limited, non-exclusive license to use these Materials to maintain or repair the subject 
Honeywell aerospace products only at the facility to which these Materials have been shipped ("the Licensed Facility").  
Transfer of the Materials to another facility owned by you is permitted only if the original Licensed Facility retains no 
copies of the Materials and you provide prior written notice to Honeywell.

2.  Rights In Materials – Honeywell retains all rights in these Materials and in any copies thereof that are not expressly 
granted to you, including all rights in patents, copyrights, trademarks, and trade secrets.  No license to use any 
Honeywell trademarks or patents is granted under this License Agreement.

3.  Confidentiality – You acknowledge that these Materials contain information that is confidential and proprietary to 
Honeywell.  You agree to take all reasonable efforts to maintain the confidentiality of these Materials.

4.  Assignment And Transfer – This License Agreement may be assigned to a formally designated service designee 
or transferred to a subsequent owner or operator of an aircraft containing the subject Honeywell aerospace products.  
However, the recipient of any such assignment or transfer must assume all of your obligations under this License 
Agreement.  No assignment or transfer shall relieve any party of any obligation that such party then has hereunder.

5.  Copies of Materials – Unless you have the express written permission of Honeywell, you may not make or permit 
making of copies of the Materials.  Notwithstanding the foregoing, you may make copies of only portions of the Material 
for your internal use.  You agree to return the Materials and any copies thereof to Honeywell upon the request of 
Honeywell.

6.  Term – This License Agreement is effective until terminated as set forth herein.  This License Agreement will 
terminate immediately, without notice from Honeywell, if you fail to comply with any provision of this License 
Agreement or will terminate simultaneously with the termination or expiration of your applicable product support 
agreement, authorized repair facility agreement, or your formal designation as a third party service provider.  Upon 
termination of this License Agreement, you will return these Materials to Honeywell without retaining any copies and 
will have one of your authorized officers certify that all Materials have been returned with no copies retained.

7.  Remedies – Honeywell reserves the right to pursue all available remedies and damages resulting from a breach of 
this License Agreement.
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8.  Limitation of Liability – Honeywell does not make any representation regarding the use or sufficiency of the 
Materials. THERE ARE NO OTHER WARRANTIES, WHETHER WRITTEN OR ORAL, EXPRESS, IMPLIED OR 
STATUTORY, INCLUDING, BUT NOT LIMITED TO, (i) WARRANTIES ARISING FROM COURSE OF 
PERFORMANCE , DEALING, USAGE, OR TRADE, WHICH ARE HEREBY EXPRESSLY DISCLAIMED, OR (ii) 
WARRANTIES AGAINST INFRINGEMENT OF INTELLECTUAL PROPERTY RIGHTS OF THIRD PARTIES, EVEN IF 
HONEYWELL HAS BEEN ADVISED OF ANY SUCH INFRINGEMENT. IN NO EVENT WILL HONEYWELL BE 
LIABLE FOR ANY INCIDENTAL DAMAGES, CONSEQUENTIAL DAMAGES, SPECIAL DAMAGES, INDIRECT 
DAMAGES, LOSS OF PROFITS, LOSS OF REVENUES, OR LOSS OF USE, EVEN IF INFORMED OF THE 
POSSIBILITY OF SUCH DAMAGES.  TO THE EXTENT PERMITTED BY APPLICABLE LAW, THESE LIMITATIONS 
AND EXCLUSIONS WILL APPLY REGARDLESS OF WHETHER LIABILITY ARISES FROM BREACH OF 
CONTRACT, WARRANTY, TORT (INCLUDING BUT NOT LIMITED TO NEGLIGENCE), BY OPERATION OF LAW, 
OR OTHERWISE.

9.  Controlling Law – This License shall be governed and construed in accordance with the laws of the State of New 
York without regard to the conflicts of laws provisions thereof.  This license sets forth the entire agreement between 
you and Honeywell and may only be modified by a writing duly executed by the duly authorized representatives of the 
parties.

Copyright - Notice

Copyright 1994, 2007 Honeywell International Inc. All rights reserved.

Honeywell and Bendix/King are registered trademarks of Honeywell International Inc.
All other marks are owned by their respective companies.
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SECTION 1
GENERAL INFORMATION

1.1 INTRODUCTION

This manual describes the operation of the Honeywell KPA 900 Configuration Module 
Programmer software version 2.0. This version differs substantially from previous 
versions. The Operator's Guide, 006-05392-0000 and 006-05392-0001, describes the 
operation with software versions 1.0, 1.1, and 1.2.

1.2 WHAT'S NEW IN VERSION 2.0

The list that follows describes the new features of the version 2.0 software:

• Compatibility with Windows NT and NT derivatives

• Standard Windows controls

• Ability to change Unit Types without exiting program

• Ability to view and edit ART 2000/2100 Stabilization Calibration

• Ability to thoroughly test CM 2000

• Ability to create log file of all user activity during programming session

• Removes support for EFIS, TCAS, and RMS units. 

1.3 SYSTEM DESCRIPTION

The KPA 900 Configuration Module Programmer consists of a KPA 900 hardware 
programmer and controlling software, which operates on an IBM-compatible personal 
computer. The programmer is designed to program the CM 2000 configuration module for 
the ART 2000/2100 weather radar systems and the KRA 405B Radar Altimeter. Previous 
versions of the KPA 900 supported configuration modules from additional systems that 
version 2.0 does not support.

The KPA 900 software has selectable configuration options for each particular system. 
These options may be stored in the Configuration Module and/or stored as a file to disk. 
User-generated comments may be added to these files. A record of user actions and the 
status of the operation are captured during the programming operation. This record may 
be saved as an electronic file. Configuration Management for the programmed modules 
is accomplished by appropriate archival of these files.
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1.4 SYSTEM REQUIREMENTS

1.4.1 MINIMUM PC REQUIREMENTS

The list that follows describes the minimum requirements for the PC:

• Pentium I Processor

• 90 MHz Clock Speed

• 64 Mb RAM

• Hard drive with 500 kB free space

• Windows 95

• CD ROM Drive

• Parallel port with the following:
– 25-pin connector
– SPP type or ECP, PS2, Fast Centronics, or EPP types with SPP compatible mode.

NOTE: The KPA 900 is designed to operate with personal computers that have operating 
systems of Windows 95 up to Windows XP. The KPA 900 has not been tested 
with the Windows Vista operating system. The hardware requirements for the 
KPA 900 are minimal compared to the operating system. If the system 
performance is acceptable without the KPA 900, the KPA 900 will not overload 
the system memory or fail to communicate with the CM 2000 because of slow 
clock speed. If the system performance suffers from lack of memory and 
frequently has to cache to the hard drive, the KPA 900 may also experience 
performance problems. 

1.4.2 KNOWN LIMITATIONS

1.4.2.1 PARALLEL PORT REQUIREMENT

Version 2.0 of the KPA 900 software is an upgrade to achieve Windows compatibility. The 
PC industry is moving away from the use of parallel ports and moving toward the use of 
USB ports. The KPA 900 is not compatible with the USB port. It has not been tested with 
a USB port to parallel port adapter, and Honeywell does not expect that it will work with 
one. In order to be USB compliant, the programmer hardware (and to some degree, the 
software) will need major redesign, which will cause an additional cost for the product. 
When the demand is great enough, Honeywell will respond with an upgrade.
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1.4.2.2 COMPATIBLE PORT NOT FOUND

The KPA 900 is designed to use the SPP type of parallel port. It can automatically 
reconfigure several varieties of ECP, PS2, Fast Centronics, or EPP types to operate in the 
SPP-compatible mode. It searches for a port at the standard base addresses of 3BC, 378, 
and 278, or accepts a user entry of a custom address. If the KPA 900 cannot find a 
compatible port, the port settings in the Windows control panel need to be adjusted to 
provide an SPP-compatible mode. See the operator’s guide for your computer to 
configure the port.

1.4.2.3 FAILED READ OR WRITE OPERATION

The KPA 900 communicates with the CM 2000 with very brief bursts of data during the 
read and write operations. Some communications are sensitive to timing variations. The 
Windows operating system does not acknowledge a user program as having a higher 
priority than the operating system. If a system-level interrupt occurs during a sensitive 
portion of a data transfer, the transfer may fail. When the failure is detected, the user is 
asked to repeat the operation. This type of failure is infrequent and should not repeat 
during a subsequent attempt at the operation. The frequency of this type of failure can be 
reduced by closing other programs, disconnecting the computer from the network, or not 
moving the mouse during read or write operations. 

1.4.2.4 INCORRECTLY REPORTED GOOD BATTERY

The KPA 900 checks the internal battery status when the program is initially invoked. 
Some computers require a longer set-up time to reconfigure the parallel port for the KPA 
900. A port that is not completely initialized may mask the failed state of the battery 
monitor and cause the KPA 900 to show that the battery is good. A CM 2000 may fail to 
program correctly with a failed battery. The software will detect and announce the failed 
operation, but will not indicate the real problem.

The personal computer retains the port configuration until another program changes it or 
the computer is shut down. If the KPA 900 repeatedly fails to correctly read or write the 
CM 2000, exit the program and start over. The battery warning will be properly displayed.
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SECTION 2
INSTALLATION

2.1 HARDWARE INSTALLATION

There are two D-type connectors on the KPA 900, a 25-pin male at the end of the ribbon 
cable and a 9-pin female on the top of the cabinet. The 25-pin connector attaches to the 
parallel port of the personal computer. The CM 2000 plugs into the 9-pin connector. See 
Figure 2-1 for the connector locations.

NOTE: Some parallel ports that are not configured can discharge the battery in the KPA 
900. For longer battery life, unplug the KPA 900 from the personal computer 
when not in use.

Figure 2-1 – KPA 900 Connector Locations

2.2 SOFTWARE INSTALLATION

There are two ways to install the KPA 900 software. There is an automatic method and a 
manual method. Both methods achieve the same result, so the choice is based on 
personal preference.

2.2.1 KPA 900 SOFTWARE IMPACT TO PC

The KPA 900 software installation is designed to have minimal impact to the computer 
operating system. It does not alter the Windows registry or install any drivers. It does 
install two .dll files, but puts them in the local directory to avoid potential version conflicts 
with other programs. All files created by the KPA 900 are stored in the local directory, 
unless the user specifies a different location. Deleting the local directory reverses the 
installation.
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2.2.2 AUTOMATIC INSTALLATION

An automatic installation program named install.exe is provided on the CD. It can be run 
through Windows Explorer or through the Run dialog box. A form, as shown in Figure 2-2, 
is displayed. Various parts of the installation program are controlled by the command 
buttons. The operation of each command button is described in the following sections.

Figure 2-2 – KPA 900 Installation Program

2.2.2.1 INSTALL

Push the Install command button to run the automatic installation program. The 
installation program creates the KPA 900 directory in root directory C: and copies the 
necessary files to it. If a previous version of the KPA 900 is installed, the program files are 
replaced. Existing configuration files and all files other than KPA 900 files in the KPA 900 
directory are saved.

2.2.2.2 RUN

Push the Run command button to run the KPA 900 program. If the program is not 
installed, pushing this button instructs the user to install the program before running it.

2.2.2.3 VIEW

Pressing the View command button will open a viewing screen and display the contents 
of the read.me file.

2.2.2.4 UNINSTALL

Push the Uninstall command button to remove all traces of the KPA 900 installation from 
the personal computer.

2.2.2.5 EXIT

Push the Exit command button to shut down the installation program.
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2.2.3 MANUAL INSTALLATION

The manual installation allows more flexibility in selection of the directory name, and 
allows a hands-on control of the file transfer. The user must create a directory with the 
name and location of choice and copy all files (except for the install.exe file) from the CD 
to the directory.

2.3 FIRST TIME OPERATION

The first time that the KPA 900 software is run, it analyzes the computer to determine the 
parallel port characteristics. When the communication between the PC and the KPA 900 
is successfully established, an .ini file is created and the applicable data is kept. This 
action may require up to a minute to complete for some computers. Each time the 
program is run after it is installed, it reads the .ini file and skips the analysis to speed up 
the KPA 900 set-up time. If the computer hardware is modified or the KPA 900 files are 
copied to another computer, the .ini file must be deleted. This file is located in the same 
directory as the installed files and is named KPA900.ini.
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SECTION 3
OPERATION

3.1 OVERVIEW

The KPA 900 provides a standard Windows interface. The controls, such as the command 
buttons, option buttons, increase/decrease controls, scroll bars, and menu controls are 
consistent in operation with any standard Windows program. There are various forms that 
may be used by the KPA 900. When a different form is necessary in response to the user's 
actions, it is displayed. When the user has completed using the form, it is removed.

3.2 KPA 900 DISPLAY VERSUS CM 2000 CONTENTS

The KPA 900 software and this Operator's Manual describe activities from the perspective 
of the form displayed on the Personal Computer, rather than from the manipulation of the 
contents of the CM 2000. When the user loads files or changes parameters, the activity 
log indicates the action followed by either "…displayed in the KPA 900" or "changed to 
XXXX in the KPA 900." The parameters are not programmed into the CM 2000 until the 
Write To CM 2000 option from the Tools menu is run. This causes the activity log to 
indicate "KPA 900 displayed parameters are being programmed into CM 2000." The 
KPA 900 display and the CM 2000 contents are only synchronized when the log 
statement "CM 2000 read and verified to be in agreement with KPA 900 displayed 
parameters" is displayed.

3.3 KPA 900 MAIN SCREEN COMPONENTS

Figure 3-1 shows a typical form that may be shown during operation of the KPA 900. The 
figure shows the various components on the form.
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Figure 3-1 – KPA 900 Main Screen Components

3.3.1 FORM CONTROLS

The form controls are the usual Windows minimize and close buttons. The maximize 
button is not available. Operation of the KPA 900 in the full-screen mode is not 
recommended.

3.3.2 ACTIVITY LOG

This window captures actions and results when the KPA 900 is in operation. This log may 
be saved to a file and kept as a work record. See Section 3.6.4 for details.

3.3.3 UNIT PARAMETERS

This field is populated with various data, depending on desired operation. Refer to Section 
3.4.1 for details about ART 2000, Section 3.4.2 for details about ART 2100, and Section 
3.4.3 for details about KRA 405B.
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3.3.4 FILE COMMENT

This is an optional field that is not displayed if a comment is not available. Users can enter 
and save comments about the configuration. The comments are stored as a line or lines 
in the configuration file. When this file is loaded into the KPA 900, the comment is 
displayed here. Refer to Section 3.6.5 for details of the comment editor.

3.3.5 MENU FUNCTIONS

The menu controls function like Windows menus. Click on a control to expand it, which 
gives options for the category. Some options are not available until a prerequisite action 
has been taken. Figure 3-2 shows the options available under the three menu items.

Figure 3-2 – KPA 900 Menu Options

3.3.5.1 FILE MENU

3.3.5.1.1 FILE → LOAD CONFIGURATION FILE

This option opens a file dialog window that allows navigation and selection of a previously 
created and stored configuration file. This feature is useful for the fleet operator or OEM 
who wants to create an identical configuration. It is also useful for the installer who wants 
to be able to recreate an existing configuration.

3.3.5.1.2 FILE → SAVE CONFIGURATION DATA
FILE → SAVE CONFIGURATION DATA AS

These options open a file dialog window that allows navigation and selection of location 
and filename for the configuration displayed on the KPA 900. Refer to Section 3.6.2 for 
details of operation.

3.3.5.1.3 FILE → ADD/EDIT COMMENT

This option opens a text-editing window that allows the user to create or alter text lines 
that are stored in the configuration file. These comment lines are helpful to determine the 
purpose of the configuration at a future date. Refer to Section 3.6.5 for details of 
operation.
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3.3.5.1.4 FILE → SAVE LOG FILE

This option saves the contents of the activity log to a file. This option is useful to an OEM 
who needs a record for quality purposes. Refer to Section 3.6.4 for details of operation.

3.3.5.1.5 FILE → EXIT

This option shuts down the KPA 900 and releases the memory back to Windows. This is 
the preferred method to exit the program, due to the memory operation. The window close 
button retains the memory allocation until the next computer restart. The KPA 900 has a 
very small memory requirement, so this is not a significant concern for most modern 
computers.

3.3.5.2 UNIT TYPE MENU

3.3.5.2.1 UNIT TYPE → ART 2000
UNIT TYPE → ART 2100
UNIT TYPE → KRA 405B

This option opens the Unit Parameter Editor frame for the selected unit type. Unlike 
previous versions of the KPA 900 software, the unit type selection is not required before 
reading the CM 2000. The unit type can also be changed without exiting the program. 
Changing the unit type or reading a module programmed with a different unit type causes 
the KPA 900 to issue a warning before changing the Unit Parameter Editor. Refer to 
Section 3.4 for details of operation.

3.3.5.3 TOOLS MENU

3.3.5.3.1 TOOLS → READ FROM CM 2000

This option transfers the configuration data contained in the CM 2000 to the unit 
parameters displayed on the KPA 900. A progress meter is displayed during the read 
operation. The activity log is updated with the status of the operation when it is complete.
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3.3.5.3.2 TOOLS → WRITE TO CM 2000

WARNING: WRITING TO THE CM 2000 OVERWRITES EXISTING DATA. IF A CM 
2000 FROM AN EXISTING INSTALLATION IS CHANGED, YOU MAY 
WANT TO READ THE MODULE BEFORE MODIFYING IT, INSTEAD OF 
LOADING THE DEFAULT CONFIGURATION FILE AND STARTING 
AGAIN. THIS IS ESPECIALLY TRUE IF THE INSTALLATION IS FOR AN 
ART, AS THE STABILIZATION CALIBRATION DATA IS LOST WITH 
THE DEFAULT FILE BUT KEPT WITH A MODULE READ.

This option transfers the unit parameters displayed on the KPA 900 to the CM 2000. A 
progress meter is displayed during the write operation. The activity log is updated with the 
status of the operation when it is complete. A successful programming operation issues a 
log statement as follows: "CM 2000 read and verified to be in agreement with KPA 900 
displayed parameters."

3.3.5.3.3 VIEW/EDIT ART STAB

This option opens a window that allows the stabilization calibration for the ART 2000 and 
ART 2100 to be viewed and calibrated. Refer to Section 3.6.8 for details of operation.

3.3.5.3.4 TOOLS → TEST → VALIDATE CM 2000

This option opens a window that allows a quick test of the operation of the CM 2000. The 
test checks that the module is working and contains the correct data. It is intended as a 
field tool to isolate the cause of a displayed CM fault. It also provides a synopsis of the 
configuration data as an aid to troubleshoot a problematic installation. Refer to Section 
3.6.6 for details of operation.

3.3.5.3.5 TOOLS → TEST → FACTORY TEST

This option opens a window that performs the factory test for the CM 2000. This is the test 
procedure used by Honeywell manufacturing before the CM 2000 is shipped. The test is 
time consuming, but may be used in the field, if desired. Refer to Section 3.6.7 for details 
of operation.

3.3.5.3.6 TOOLS → RESTART

This option clears the activity log and reverses any changes that have not been 
programmed into the CM 2000.
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3.4 UNIT SPECIFIC CONFIGURATION OPERATION

3.4.1 UNIT TYPE → ART 2000

The KPA 900 allows the user to specify optional characteristics and optional features for 
the ART 2000 weather radar. Refer to Section 4.1 for a description of the parameter 
function. Differences in the feature sets of the ART 2000 and ART 2100 are controlled by 
the unit hardware and software. Attempts to configure an ART 2000 to provide an ART 
2100 feature through the CM 2000 will not provide the feature and may cause malfunction.

3.4.1.1 DISPLAYING ART 2000 PARAMETERS

The ART 2000 parameter frame is displayed by selecting the ART 2000 from the Unit 
Type menu, loading a configuration file for ART 2000, or reading a CM 2000 that is 
programmed for ART 2000. Figure 3-3 shows the ART 2000 parameter frames with the 
default values.

There are two pages of parameters available, but only one can be viewed at any time. The 
page that is not on screen is viewed by moving the vertical scroll control to the upper or 
lower position.

Figure 3-3 – KPA 900 Main Form with ART 2000 Unit Type Selected

3.4.1.2 CHANGING ART 2000 PARAMETERS IN THE KPA 900

The options available for each parameter are listed as option buttons grouped in a frame 
with the parameter name. To select a different option for the parameter, click on the 
desired option. The selected option receives the black dot inside the circle which indicates 
a successful selection. A line is added to the activity log to indicate the change and the 
new value.
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The purpose of the stabilization calibration status frame is to give information only. It 
indicates that a stabilization calibration has or has not been performed on the ART. This 
information is useful when there is any doubt that the result of the calibration procedure 
was successfully stored in the CM 2000. Refer to Section 3.6.8 for the procedure to view 
or change the calibration.

When the unit parameters are changed, only the displayed value is changed. The 
CM 2000 is not updated. Thus, the data must still be written to the CM 2000.

3.4.2 UNIT TYPE → ART 2100

The KPA 900 allows the user to specify the desired optional characteristics and optional 
features for the ART 2100 weather radar. Refer to Section 4.1 for a description of the 
parameter function. Differences in the feature sets of the ART 2000 and ART 2100 are 
controlled by the unit hardware and software. Attempting to configure an ART 2000 to 
provide an ART 2100 feature through the CM 2000 will not provide the feature and may 
cause malfunction.

3.4.2.1 DISPLAYING ART 2100 PARAMETERS

The ART 2100 parameter frame is displayed by selecting the ART 2100 from the Unit 
Type menu, loading a configuration file for an ART 2100, or reading a CM 2000 that has 
been programmed for an ART 2100. Figure 3-4 shows the ART 2100 parameter frames 
with the default values.

There are two pages of parameters available, but only one may be viewed at any time. 
The page that is not on screen is viewed by moving the vertical scroll control to the upper 
or lower position.

Figure 3-4 – KPA 900 Main Form with ART 2100 Unit Type Selected
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3.4.2.2 CHANGING ART 2100 PARAMETERS IN THE KPA 900

The options available for each parameter are listed as option buttons grouped in a frame 
with the parameter name. To select a different option for the parameter, click on the 
desired option. The selected option receives the black dot inside the circle which indicates 
a successful selection. A line is added to the activity log to indicate the change and the 
new value.

The purpose of the stabilization calibration status frame is to give information only. It 
indicates that a stabilization calibration has or has not been performed on the ART. This 
information is useful when there is any doubt that the result of the calibration procedure 
was successfully stored in the CM 2000. Refer to Section 3.6.8 for the procedure to view 
or change the calibration.

When the unit parameters are changed, only the displayed value changes. The CM 2000 
is not updated. Thus, the data must still be written to the CM 2000.

3.4.3 UNIT TYPE → KRA 405B

The KPA 900 allows the user to specify optional characteristics for the KRA 405B Radar 
Altimeter. Refer to Section 4.2 for a description of the parameter function.

3.4.3.1 KRA 405B PARAMETERS

The KRA 405B parameter frame is displayed by selecting the KRA 405B from the Unit 
Type menu, loading a configuration file for a KRA 405B, or reading a CM 2000 that has 
been programmed for a KRA 405B. Figure 3-5 shows the KRA 405B parameter frame with 
the default values.
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Figure 3-5 – KPA 900 Main Form with KRA 405B Unit Type Selected

3.4.3.2 CHANGING KRA 405B PARAMETERS IN THE KPA 900

Click the change button under any of the four parameters frames to show a change 
window similar to Figure 3-6. The title of the window and the interior frame title specify the 
parameter to be changed.

Figure 3-6 – KPA 900 KRA 405B Parameter Change Form
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There are two values shown in this window, the current value shown in the KPA 900 and 
the new value to be set. Initially, the two values are the same. The increase/decrease 
control in the new value frame is used to adjust the new value to the desired setting.

There are two command buttons on this window, Cancel and Save. The Cancel button 
closes the window without transferring the changes to the KPA 900. The Save button 
closes the window and transfers the changes. Changes are only transferred and 
displayed on the KPA 900 and are not programmed into the CM 2000.

3.5 CM 2000 INPUT/OUTPUT OPERATIONS

The basic CM 2000 Input/Output operations are the writing of configuration data to the 
module, and the reading and displaying of the configuration data that is stored in the 
module.

3.5.1 TOOLS → WRITE TO CM 2000

The Write to CM 2000 option in the Tools menu transfers the configuration data displayed 
on the KPA 900 to the CM 2000. The activity log includes the line "KPA 900 displayed 
parameters are being programmed into CM 2000" as the write operation starts.

During the write operation, the mouse pointer changes to an hourglass and a progress 
meter is displayed over the top of the activity log. As the writing progresses, the white 
rectangles in the progress meter change to black. When the write operation is completed, 
the progress meter is removed and the mouse pointer is restored. 

The KPA 900 reads the CM 2000 and verifies that the contents are in agreement with the 
displayed parameters (and additional validity requirements). It then records the result in 
the activity log. A successful write operation is denoted by the message, "CM 2000 read 
and verified to be in agreement with KPA 900 displayed parameters." A failed write 
operation is denoted by the message, "CM 2000 contains corrupt data. Memories are not 
identical." The exact message that is generated depends on the failure.

If the KPA 900 fails to successfully write the module, try the write operation again. Refer 
to Section 1.4.2 for instructions. The failure may also be caused by a defective CM 2000.

3.5.2 TOOLS → READ FROM CM 2000

The Read from CM 2000 option in the Tools menu transfers the configuration data stored 
in the CM 2000 to the KPA 900 display.

During the read operation, the mouse pointer changes to an hourglass and a progress 
meter is displayed over the top of the activity log. As the reading progresses, the white 
rectangles in the progress meter change to black. When the read operation is completed, 
the progress meter is removed and the mouse pointer is restored.
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The KPA 900 verifies that the contents of the CM 2000 are validated for legitimate and 
reasonable data and if valid data is displayed on the unit parameters form. If required, the 
KPA 900 selects the appropriate unit type, based on the read data. The message, 
"Module has been read and validated, parameters for the ART 2000 are displayed in the 
KPA 900" is placed in the activity log if the read operation is successful. A failure to 
successfully read the module is indicated by a statement similar to "CM 2000 does not 
contain any data. Verify that the module is installed."

If the KPA 900 fails to successfully read the module, try the read operation again. Refer 
to Section 1.4.2 for instructions. The failure may also be caused by a defective CM 2000, 
or the data in the module may be corrupted. Refer to Section 3.6.6 for instructions on 
finding corrupted data.

3.6 MISCELLANEOUS OPERATIONS

The following operations are not required for basic programming of the CM 2000, but 
extend the function of the tool to make it easier to operate or to provide enhanced 
capability. These tools are used at the discretion of the operator, or as necessary.

3.6.1 FILE → LOAD CONFIGURATION FILE MENU OPTION

A previously saved configuration can be recreated by loading a configuration file. The 
configuration can be duplicated or modified. The Load File form, similar to that shown in 
Figure 3-7, is displayed. Refer to Section 3.6.2 for details about using this form.

3.6.2 FILE → SAVE CONFIGURATION DATA AS MENU OPTION

When all parameters in configuration are determined, the configuration is saved to a file, 
or a programmed CM 2000 from an installation is read and the data is stored in a file. 
These stored files provide a record for the aircraft documentation, and can also be loaded 
back into the KPA 900 and programmed into additional CM 2000s.

Figure 3-7 shows the form displayed when the File → Load or File → Save Configuration 
Data As menu options are selected. The title on the form differs with each option selected. 
This form differs slightly from the standard Windows file form. This allows compatibility 
with 16- or 32-bit file structures. The operation of this form is explained in the following 
sections.
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Figure 3-7 – File Load and File Save As Form

3.6.2.1 LOOK IN NAVIGATION

The Look In frame contains three fields: the Drive list, the Directory list, and the File list. 
The navigation goes to the directory path of the KPA 900. If the configuration files are 
stored in this location, it is not necessary to navigate further.

To select a different drive, click the expand arrow next to the drive designation and click 
on the desired drive. The directory and file lists update for the root of the selected drive.

To select a directory at a lower level than is shown, click on the directory name. See 
Section 3.6.2.2 to select a directory at a higher level. The file list updates for the selected 
directory.

The file list only displays KPA 900 configuration files. These files have an .rdr extension. 
If there are no files of this type, the file list is empty. Double click on a file name to transfer 
the name to the File Name text box.

3.6.2.2 UP ONE LEVEL COMMAND BUTTON

The Up One Level command button has an icon with a folder and an upward arrow. 
Choose this command to select and display the parent directory of the directory on 
screen. The file list updates for the selected directory.
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3.6.2.3 CREATE NEW DIRECTORY COMMAND BUTTON

The Create New directory command button has an icon with a folder. This command 
creates a new directory to store the configuration file. The new directory is located in the 
directory that is currently selected. Choose this command to open a text entry box. Type 
the name for the new directory in the text entry box and click the OK command to create 
the directory.

3.6.2.4 FILE NAME FIELD

The File Name field contains the name of the file to be loaded or saved. Type a name into 
this field or double click on a name to select it from the file list. Do not use the .rdr 
extension when saving the file.

3.6.2.5 CANCEL COMMAND BUTTON

The Cancel command button closes the File Load or File Save form without saving any 
changes.

3.6.2.6 OK COMMAND BUTTON

The OK command button loads the file name into the KPA 900 or creates a configuration 
file with the chosen file name. If the unit type is not selected before a file load, the KPA 
900 makes the unit type selection based on the file contents. 

NOTE: During a file load, the KPA 900 tests the file before the results are shown. The file 
data is tested for valid characters, correct structure, line numbering, and data 
boundaries. If the file is corrupted, the KPA 900 does not accept it. If there is a 
failure, a message box is displayed with a description of the problem. It may be 
possible to correct a corrupted file by opening it with a text editor and correcting 
the message box complaint.

3.6.3 FILE → SAVE MENU OPTION

If a previously saved and named file is modified and it is not necessary to keep the original 
file, select the File → Save Configuration Data menu option. This option replaces the 
existing file with the new file and keeps the same file name. The KPA 900 requests 
confirmation before the existing file is overwritten. Figure 3-8 shows the confirmation 
message box. Select the Yes command to save the changed file. Select the No command 
to save the file with a different name. When this option is selected, the message box 
changes to the Save File As form. Select the Cancel command button to close the 
message box without saving any changes.
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Figure 3-8 – Continue with Save Message Box

3.6.4 FILE → SAVE LOG FILE

The Activity Log window keeps a record of every operator action and the status of the KPA 
900 response. This record is valuable as a diagnostic tool or as a quality record that 
describes the steps and results of the programming section of the programming operation. 
An electronic file is created in ASCII text format which can be archived or printed based 
on the operator requirements.

To run the Save Log File operation, select the Save Log File option from the File menu. 
No window is displayed and there are no options to select a different file name. A 
time-stamped log file is created in the KPA directory when this option is selected. The 
format of the file name is similar to 07-23-07_25910PM.log. The text line "Activity log for 
KPA 900 Configuration Module Programmer" followed by a blank line is inserted into the 
file. A copy of the contents of the Activity Log window is stored in the file.

3.6.5  FILE → ADD EDIT COMMENTS

Select the Add Edit Comments option from the File menu to add or edit comments. A 
Comment Field Editor frame is displayed as shown in Figure 3-9. Not all command 
buttons are enabled, but the Active Line text box is visible at all times.
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Figure 3-9 – KPA 900 Main Form with Comment Editor Selected

3.6.5.1 FILE COMMENTS FIELD

The existing comment is displayed in the File Comments field. The field may contain 
multiple lines. The field is not directly edited because the KPA 900 places a special 
character at the beginning of each comment line. Data lines do not use special characters. 
The special characters identify real comments or a possible file corruption. A line of invalid 
data without a special character is considered to be corrupted data. The special 
characters are internally created by the KPA 900. This action is not visible to the user.

When a file is saved, the contents of this field are saved with the file. If the file is not saved 
before exiting the KPA 900, the comment changes are lost.

3.6.5.2 TEXT ENTRY FIELD

All editing takes place in the Text Entry field. Push the New Line command button or the 
Edit command button to access the Text Entry field. When the field is visible, click on it to 
show a vertical bar at the position of the mouse pointer. This is the insertion point. Insert 
the desired text or delete unwanted text until the line is correct.
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3.6.5.3 CLEAR COMMAND BUTTON

The Clear command button deletes all of the text in the File Comments field. Text in the 
Active Line field is unaffected.

3.6.5.4 FINISHED COMMAND BUTTON

The Finished command button removes the Comment Editor frame and restores the last 
used Unit Parameter frame. Any text that remains in the Active Line field is not transferred 
to the File Comments field, but is retained in the Active Line field while the KPA 900 
program is running.

3.6.5.5 NEW LINE COMMAND BUTTON

The New Line command button makes the Active Line field available if it is not shown, or 
it clears the contents if it is already shown.

3.6.5.6 SAVE LINE COMMAND BUTTON

The Save Line command button transfers the contents of the Active Line field to the File 
Comments field. The line of text is added as the last entry in the field.

3.6.5.7 SELECT COMMAND BUTTON

The Select command button highlights a line of text in the File Contents field. Click on this 
button multiple times to cycle through all available lines of text. Click on a line of text to 
select it.

3.6.5.8 EDIT COMMAND BUTTON

The Edit command button works with the Select command button. When a line of text is 
selected and the Edit command button is clicked, the contents of the text line are 
transferred to the Active Line field.

3.6.5.9 INSERT COMMAND BUTTON

The Insert command button works with the Select command button. When a line of text is 
selected and the Insert command button is clicked, the contents of the Active Line field 
are inserted into the File Comments field after the selected line.
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3.6.6 TOOLS → TEST → VALIDATE CM 2000

The Validate CM 2000 operation is invoked by selecting the Test and Validate CM 2000 
option from the Tools menu. A validation window is shown in Figure 3-10.

Figure 3-10 – Validate CM 2000 Form, Initial Screen

Push the Start command button to show the Dialog boxes for the Unit Type, the 
Configuration Parameters, and the Stabilization Calibration as shown in Figure 3-11. The 
user must respond to these questions for the test to continue. At the end of the test, a 
summary of the results is shown as in Figure 3-12.

Figure 3-11 – Validate CM 2000 Form, Configuration Screen

Figure 3-12 – Validate CM 2000 Form, Conclusion Screen
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3.6.7 TOOLS → TEST → FACTORY TEST

The Factory Test is a Honeywell manufacturing tool that tests all memory locations in the 
CM 2000. The test writes several data patterns to each memory location and then reads 
the patterns for validation. It is a time-consuming test and is of little value to the field. This 
test can be used in the field to clear non-zero data that exists a section of memory that is 
not used. This procedure is able to overwrite an existing configuration and, more 
importantly, remove an ART stabilization calibration. To avoid this problem, be sure to 
check the "Preserve Module Contents" before the test is started.

Select the Test → Validate CM 2000 options from the Tools menu to run the Factory Test 
operation. A validation window is shown as in Figure 3-13. Push the Partial command 
button to open a window that allows the user to specify only the test patterns of interest, 
rather than the entire test. Push the Start Test command button to start the test.

Figure 3-13 – Factory Test Form, Initial Screen

Figure 3-14 shows a test in progress. When the test is complete, the serial number and 
test status are transferred to the Activity Log in the main KPA 900 form. Push the Quit 
command button to close this form and re-open the main form.
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Figure 3-14 – Factory Test Form, Test in Progress Screen

3.6.8 TOOLS → VIEW EDIT ART STAB

CAUTION: BE CAREFUL WHEN YOU ADJUST THE VALUES, AS YOU WILL ALTER 
THE EXISTING CALIBRATION DATA. MAKE SURE TO DO A MODULE 
READ OPERATION, AND SAVE THE CONFIGURATION AND 
CALIBRATION TO A SEPARATE FILE BEFORE YOU MAKE ANY 
ADJUSTMENTS. THIS FILE CAN BE RESTORED IF NECESSARY.

The View/Edit ART Stab tool provides a way to see the results of a stabilization calibration 
and to make adjustments if necessary. The CM 2000 must be read through the 
Tools → Read from CM 2000 menu option, and then through the 
Tools → View/Edit ART Stab menu option.

NOTE: The preferred method of performing a stabilization calibration is included in the 
installation manual for the ART. This is an alternative procedure to slightly modify 
an existing calibration that is not working as expected.

Figure 3-15 shows the View/Edit ART Stab Calibration form with the uncalibrated default 
values. There are two main frames, one for the analog gyro and one for the digital gyro. 
Only the values for the configured gyro source are significant to the ART.

To find if the system is calibrated, compare the existing display with the default values 
shown in Figure 3-15. A calibration was completed if any field has been changed.
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Figure 3-15 – ART Stab Calibration Form with Default Values Shown

3.6.8.1 ANALOG GAINS

The Analog Gyro Reference Gain, Pitch Gain, and Roll Gain represent the scale factor 
applied to the multiplying ADC in the ART. The ART then translates the gyro voltage to 
the calibrated level for the angle given by the gyro. When the gyro voltage is the same as 
the calibration voltage, the ART scales that voltage to the equivalent angle. If the gain to 
the ADC is increased, the ART scales the voltage to a lower value and interprets the angle 
as a smaller angle.

Make sure to observe how the direction of the desired change affects the operation. 
Reverse the direction of the change to compensate for the direction not calibrated. Make 
changes as necessary and record all adjustments for future reference. If the calibration is 
unsuccessful, you can restore the saved file or do a complete calibration. Refer to the ART 
installation manual for instructions on how to do a complete calibration.

3.6.8.2 ANALOG OFFSETS

The Analog Gyro Pitch Offset and Roll Offset show the deviation from zero degrees given 
by an analog gyro when the aircraft is in level flight. These values are typically close to 
zero with a gyro that is calibrated and functions properly.

3.6.8.3 ANALOG NULLS

The Analog Gyro Pitch Null and Roll Null show the deviation from zero volts when the 
aircraft is in level flight. These values are typically zero with a gyro that is calibrated and 
functions properly. The air-driven panel-mount gyros sometimes have a non-zero value in 
this field.
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3.6.8.4 DIGITAL OFFSETS

The Digital Offsets show the deviation from zero degrees given by a 429 gyro when the 
aircraft is in level flight. These values are typically low, which shows there may be 
mechanical mounting errors for the gyro and the ART. There is no gain adjustment for the 
429 gyro. 

3.6.8.5 SAVE COMMAND BUTTON

The Save command button transfers the values in this form and any values in the main 
KPA 900 form to the CM 2000. This is unlike other KPA 900 operations that require you 
to select the Tools → Write to CM 2000 menu commands. This tool is used to save 
adjustments to a CM 2000 that is already configured and calibrated.

3.6.8.6 CANCEL COMMAND BUTTON

The Cancel command button closes the ART Stab Calibration form and makes the main 
KPA 900 form active. Any changes made after the last save are ignored.

3.6.8.7 CLOSE COMMAND BUTTON

The Close command button closes the ART Stab Calibration form and makes the main 
KPA 900 form active. Any changes made after the last save are ignored.

3.7 TYPICAL OPERATION OF THE KPA 900

The following scenarios describe some typical operations of the KPA 900.

3.7.1 NEW INSTALLATION OF AN ART 2100

1. Invoke the KPA 900 operation.

2. Unit Type → ART 2100.

3. Adjust the parameters as necessary.

4. Tools → Write to CM 2000.

5. Verify the activity log.

3.7.2 CHANGING THE TRIP POINT #1 OF AN EXISTING KRA 405B INSTALLATION

1. Invoke the KPA 900 operation.

2. Tools → Read CM 2000.
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3. Click on Trip Point #1 Change.

4. Adjust the parameters as necessary.

5. Click on the Save button.

6. Tools → Write to CM 2000.

7. Verify the activity log.

3.7.3 PROGRAMMING A NEW CM 2000 FOR AN OEM

1. Invoke the KPA 900 operation.

2. File → Open Configuration File.

3. Select the desired file.

4. Tools → Write to CM 2000.

5. Verify the activity log.

6. File → Save Log File.

3.7.4 TROUBLESHOOTING A CM FAULT

1. Invoke the KPA 900 operation.

2. Tools → Test → Validate CM 2000.

3. Click Start on the Validate form.

4. Respond to the questions as necessary.

5. Verify the log file.

NOTE: The installer must verify that the system functions correctly in the aircraft. Never 
assume that a parameter is functional based solely on the KPA 900.
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SECTION 4
UNIT PARAMETER DEFINITIONS

4.1 ART 2000 AND ART 2100 PARAMETERS

4.1.1 GYRO SOURCE

The Gyro Source parameter shows the two potential sources for the gyro data. When the 
429 Bus option is selected, the Analog Gyro Type and the Gyro Compensation options 
are ignored and do not affect the ART.

4.1.2 ANALOG GYRO TYPE

The Analog Gyro Type indicates the value of the reference voltage from the gyro. 
Selection of the Unknown option causes the calibration to take longer. The calibration 
does not have optimum resolution when this option is selected.

4.1.3 ANALOG GYRO COMPENSATION

The reference voltage for some analog gyros decreases in operation. The decreased 
voltage is more noticeable under heavier loads. When the voltage decreases, the pitch 
and roll gain values are too high. Select the Compensate For Droop option to set the gain 
values in ratio of the initial reference voltage to the current reference voltage. 

4.1.4 MECHANICAL SCAN LIMIT (ART 2100 ONLY)

The mechanical scan for the ART 2100 may be limited to 100 degrees to accommodate 
installations where space limitations under the radome cause interference with the 
antenna movement. The stop screw in the segmented gear must be moved to the 
appropriate position. Hard-start calibration must be done when the mechanical scan limit 
is changed. 

4.1.5 CONNECTOR POSITION

The Connector Position is the orientation of the 50-pin unit connector on the ART. The 
ART is mounted with the connector at the 12 o'clock position (top) or the 6 o'clock position 
(bottom). When the correct connector position is set, the ART to moves the antenna in the 
correct vertical axis with the tilt knob. This gives the correct left/right scan position 
information.

4.1.6 ALTITUDE SOURCE (ART 2100 ONLY)

The Altitude Source parameter shows the two potential sources for the altitude data for 
the autotilt feature. The choices are the ARINC 429 bus or the discrete bits from the 
Gilham (ARINC 575) bus. Selection of the ARINC 429 option limits the system to two 
controller inputs.
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4.1.7 DESIRED ANTENNA SWEEP

The Desired Antenna Sweep limits the radial angles of the weather data to the display 
units. The antenna sweeps completely to the limit, but only the data accumulated to the 
Desired Antenna Sweep option is displayed. Scan time is not reduced, and scan 
interference is not corrected with this parameter. It may be useful to decrease the desired 
sweep when non-Honeywell displays are interfaced, or in installations where there is a 
problem with false reflections at the periphery.

4.1.8 WX GAIN (ART 2100 ONLY)

In the weather mode, the ART receiver gain can be adjusted when the Wx Gain is 
enabled. Wx gain adjustments can give more data about storm intensity if it is determined 
that a cell is just over a color threshold or is near the next color threshold. Wx Gain is used 
to make the determination of the proximity to the threshold. This option allows operation 
of the WxR in an uncalibrated mode. Do not enable the Wx Gain option, unless the display 
unit annunciates the uncalibrated condition.

4.1.9 MAP GAIN

In the map mode, the ART receiver gain can be adjusted when the Map Gain is enabled. 
Map gain adjustments can give more data about the ground reflection by shifting the 
thresholds to sharpen the edges of the gradients. The map mode is not a calibrated 
display. Thus, the absolute colors are insignificant in terms of the reflective surface. 
Surfaces of varying reflectivity can be effectively separated by an adjustment of the gain.

4.1.10 EFIS STRUT SWITCH

The EFIS Strut Switch (WOW) inhibits the transmitter when the aircraft is on the ground. 
This is a safety feature designed to protect ground personnel and to prevent possible 
damage to the ART. The Strut Switch Override allows the ART to ignore a transmitter 
inhibit one time for testing purposes. This option is set with the EFIS configuration menu 
and is also available with the KPA 900. 

4.1.11 ARL (ART 2100 ONLY)

When enabled and selected, the ARL feature determines when the losses due to 
intervening weather are too great to accurately display the weather. This occurs when the 
ART does not have sufficient strength to penetrate a storm cell due to losses in the 
intervening weather. Areas behind the storm that are not monitored show as blue to warn 
the operator of potentially dangerous conditions.
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4.1.12 AUTO STEP SCAN (ART 2100 ONLY)

When enabled and selected, the Auto Step Scan feature adjusts the tilt by 4 degrees at 
the edge of a scan. The Auto Step Scan does a volumetric scan of the airspace ahead of 
the aircraft. Auto Step Scan is only available for EFIS systems with certain versions of the 
Radar Control Panel.

4.1.13 SECTOR SCAN (ART 2100 ONLY)

When enabled and selected, the Sector Scan feature limits the sweep to a narrower 
sector, centered on the track line. Sector Scan permits a faster update rate of a smaller 
area of interest. Sector scan is only available for EFIS systems with certain versions of the 
Radar Control Panel.

4.1.14 AUTO TILT (ART 2100 ONLY)

The Auto Tilt feature adjusts the antenna tilt to an angle that provides a consistent ground 
clutter presentation when range or altitude changes.

4.1.15 TARGET ALERT

When enabled, the Target Alert feature warns the operator of significant weather activity 
that is occurring beyond the selected range.

4.2 KRA 405B PARAMETERS

The use of the CM 2000 is optional on a KRA05B. The default parameters are stored in 
the KRA 405B and are applied when there is no CM 2000 attached to the system. The CM 
Fault is only issued for a reading of a corrupted module, and not for a missing module.

4.2.1 ZERO FOOT OFFSET

The Zero Foot Offset permits the KRA 405B to display zero feet when the aircraft is in a 
position higher than it was at the zero foot calibration. The Zero Foot Offset is a constant 
value that is subtracted from the measured altitude. Use of a Zero Foot Offset allows an 
aircraft with the radar altimeter antennas located ahead of the landing gear to report zero 
feet altitude when the gear touches ground. An offset that allows an altitude reading of 
less than -20 feet produces a failure.

4.2.2 TRIP POINT #1, TRIP POINT #2, AND TRIP POINT #3

All trip points are used to toggle their states to an external device when a specified altitude 
threshold is achieved. There are three independently programmable trip points available. 
Each one corresponds to a unique discrete output from the KRA 405B.
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